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After having learned this lesson you will be more familiar with the following topics:  
 Different Authoring tools for eLearning websites 
 Basic aspects of the work with Macromedia Dreamweaver 
 Important steps for building an eLearning course with Dreamweaver 
 Content converters and their use 

 
CONTENT OF THE LESSON  
 1. Authoring Tools for eLearning Websites: Overview 
 2. Authoring Tools for eLearning Websites: Macromedia Dreamweaver MX 
 3. Worked examples with Dreamweaver MX 
 4. The use of the Content Converters.  
       How to use. 

 
LEARNING OBJECTIVES:  
After having learned this lesson you will have accomplished the ability to: 
 Have an Overview of Web Authoring Tools for eLearning Courses 
 Know basics for building an eLearning Course with Dreamweaver MX 
 Know how to develop an eLearning Course in practice with Dreamweaver MX 
 Use Content Converters for eLearning Courses 

 
1. Authoring Tools for eLearning Websites: Overview 
 
Website authoring tools for eLearning content have the function to help an eLearning author to create eLearning content for 
the Web. 
Normally they are combined with special media editors to create the media files in a first step. In the next step the eLearning 
author combines the media files with textual content inside the website authoring tool. 
 
There are many reasons for using website tools for eLearning: 

- Many learners use the Web for learning anywhere 
- When the eLearning content is presented in the Internet many learners can use the content simultaneously. 
- It is much easier to update content in the Web than produce new CD-ROMs. 
- It is possible to integrate learning content with other Web offerings. 

 
Here you see an example for an eLearning module created with Macromedia Dreamweaver: 
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Figure 1: An eLearning module created with Macromedia Dreamweaver 

 
1.1. Tools for the authoring of eLearning content 
 
Today there are many tools for authoring of eLearning content: 
 
Macromedia Dreamweaver 
Dreamweaver is a very well known Website authoring software. 
It has many features and simplifies the creation of eLearning content. 
 

 
Figure 2: Dreamweaver from Macromedia is a very well known web site authoring tool 

 
Microsoft Frontpage 
The user interface of Frontpage is very similar to the Microsoft Office package. If an author is familiar with Office, for him 
or her it should be easy to work with this software. 
The text formatting possibilities are nearly the same as in Microsoft Word or PowerPoint. 
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Adobe GoLive 
GoLive is also a powerful Web authoring tool. 
Users who choose GoLive normally also work with Photoshop or Illustrator from Adobe because the interfaces are very 
similar. 
One advantage of GoLive is, that you can author QuickTime movies and SMIL presentations without using an external 
editor. 
 
NetObjects Fusion 
NetObjects Fusion is much cheaper than Dreamweaver or GoLive, the tools presented above. It costs about 120 Euros instead 
of about 400 Euros. 
You can use nearly all the basic tools to create an eLearning Web site. 
 
1.2. Other Tools 
 
Here are some of the other WYSIWYG-Editors available: 
 
Product Vendor Web address 
Hot Metal Pro Corel www.corel.com 
Netscape Composer Netscape www.netscape.com 
Amaya Browser World Wide Web Consortium www.w3c.org 

Figure 3: Other tools for website editing 
 
2. Authoring Tools for eLearning Websites. Macromedia Dreamweaver MX 
 
In the next part of the lesson you learn more about Macromedia Dreamweaver, some of the main parts of the user interface 
and the process of course design. 
 
2.1 Basics for building an eLearning Course with Dreamweaver MX 
 
The website creation workflow with Dreamweaver  
 
What do you have to think about in order to create a website with Dreamweaver? 
 

- First you define a site’s strategy or goals.  
- You set up a server and maybe a database. 
- The next part is to think about the look and feel of the site 
-  You create the site by coding the pages 
- The content and possibilities for interactivity have to be added 
- The pages have to be linked together 
- At the end you test the site and publish it on a server. 

 
The user interface of Dreamweaver consists of the following parts: 
 
The integrated Dreamweaver workspace 
In Dreamweaver all windows and tools are integrated into one workspace. 
So you don’t have to change between applications for the creation of your Web site. 
 
Windows and Panels 
Dreamweaver MX offers many different windows and panels: 
 

- The Welcome window offers tips, information and new features for beginners and advanced users. 
- With the Insert bar you can insert different (media) objects like images, tables, and layers. If you want to 

integrate an image, you just click on “Insert” > “Image”. 
- The Document toolbar is very useful to change between different views of the Document window (such as 

Design view and Code view), moreover you find various viewing options, and operations like previewing in a 
browser. 

- The Standard toolbar (not displayed in the default workspace layout) offers standard buttons like: 
New, Open, Save, Save All, Cut, Copy, Paste, Undo, and Redo. If the Standard toolbar is not visible, choose  
View > Toolbars > Standard. 

- In the Document window you see the current document as you create and edit it.  
- The Property inspector offers possibilities to change many properties for the object you just have selected. 
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- With the help of the tag selector in the status bar at the bottom of the document window you get an insight of 
the tag hierarchy of your position in the code you write at the moment.  

- Panel groups a number of closed panels one over each other. If you click on a closed panel you can expand it. 
- In the Site panel you get an overview of all the files and folders you have defined as part of your site. 

 
If you work with Dreamweaver you can use other panels like the History panel and the Code inspector. 
 
2.2. Course Design with Dreamweaver MX 
 
How do you design a course with Dreamweaver? 
 
For the process of designing a website with Dreamweaver the following steps are very helpful 
 
Think about your goals 

- What do you want to sell with your site? 
- Do you want to inform the target group with special information? 
- Write your goals for the rest of the process down. 

 
Think about your target audience 

- After thinking about your goals you should think about the target group for your website. 
- For every special target group you need a special layout or presentation style. 
- Different target groups may use different technologies like browsers or players to access your offerings. 
- Think about the platform of your users. 
- Different users may work with different computers or monitors. 
- What kind of internet connection do your users have? 

 
Think about browser compatibility 
The browser compatibility is one of the most important aspects during the website creating process: 
 
One of the following browsers may be the browser your visitors use most: 

- Netscape Navigator 
- Microsoft Internet Explorer (used by most of the current surfers) 
- AOL-Browser 
- Text browsers like Lynx 

 
Normally the best choice would be to create a web site for as many browsers as possible. 
 
The following aspects may prevent you from creating a web site with compatibility for different browsers: 

- All the people in your company use the same browser 
- You produce your Web site inside an information system which can only be accessed by one type of browser 

e.g. the information offerings at a POI. 
- You distribute your content on CD-ROM and save the best-to-use browser version on CD. 

 
Think about the site structure 
From the beginning it is very useful to organise your site and your content very carefully. 
 
Here are some steps to help you organise: 

- Create a target folder for the whole web site on your local disc 
- Divide the content in categories 
- Create subfolders for the different categories 
- Group related web pages in the same subfolder 
- Place the media files in special subfolders so that you are able to find them quickly again 
- Maybe you use one main folder for all non HTML files called “Assets” 
- Use the same site structure for your local and your remote site. 

 
Think about your design look 
It is much easier to determine the design look of your site at the beginning of your work than change many pages later. 

- Find the right colours that may interest your target group 
- Set up the font sizes of text and headlines 
- Think about what kind of site elements should be visible on the user interface 

 
Think about the navigation scheme 
The navigation scheme of your website should be as user friendly as possible. 
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If the users get lost in your website maybe they will never visit it again. 
 
2.3. Developing an eLearning Course with Dreamweaver MX 
 
The following steps are necessary to develop an eLearning Course with Dreamweaver MX: 
 
Define the site 
If you choose Site > New, you can create and define a new Web site 
 

 
Figure 4: Define a new website with Dreamweaver 

 
Create Templates 
To create a new template click File > New and choose “Template” 
 

 
Figure 5: Create a new Template in Dreamweaver 

 
Create a Stylesheet 
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To create a new template click File > New and choose “CSS-Stylesheets” 
 

 
Figure 6: Create a CSS-Stylesheet with Dreamweaver 

 
Site structure 
You can also control the structure of your site. 
 

 
Figure 7: Example for the structure of a Web site 

 
Create Pages 
To create a new Page click File > New and choose “Page” 
 

 
Figure 8: Create new pages with Dreamweaver 

 
3. Working examples with Dreamweaver MX 
 
Now we start to elaborate a small Web site with Dreamweaver MX. 
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Step 1: Create a new folder on your local machine 
Define a place for the storing of your website on your local machine. 
Create a new folder. 
Name the folder in a way that you can easy identify it later. 
 

 
Figure 9: Windows Explorer with the context menu to create a new folder 

 
 
Step 2: Create a new Web site in Dreamweaver 
To create a new Web site in Dreamweaver open Site > New. 
Choose a name for the Web site and search the folder you have created before. 
Click “OK”. 

 
Figure 10: the Site definition window in Dreamweaver 

 
In the Site panel on the right you can see the folder for your new website now. 
 

 
Figure 11: the site panel with the folder for the new website 

 
Step 3: Create a template for the website 
Open the template window with File > New > Template. 
Select “HTML-Template”. 
Click “Create”. 
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Figure 12: the window for the creation of a new template 

 
With the “Insert / Template” window you can add specific template elements to your template. 
 

 
Figure 13: the insert window with the template manager 

 
Step 4: Create and add a Stylesheet 
After creating your template you can add a stylesheet. 
Choose “File > New > CSS-Stylesheets” and use one of the given styles. 
Save the Stylesheet into your project folder. 
 

 
Figure 14: the Stylesheet selection window 

 
Now you can add the Stylesheet to your template. 
 
Step 5: Create your HTML-pages 
With the help of your template you can create your HTML-pages now. 
Fill your content into the required spaces in your template and save the files into your project folder. 
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Figure 15: one of the created Web pages in Dreamweaver 

 
Step 6: Test your website in your browser 
Open your browser and test the result of your work. 
 

 
Figure 16: the small website in Internet Explorer 

 
5.4. The use of the Content Converters. How to use. 
 
Content converters are applications which convert one file format to another. They especially are very useful if we want to 
convert one existing file into more than one different format. 
For example you have a Microsoft PowerPoint file but you want to integrate it into your learning platform as a Macromedia 
Flash file. 
 
5.4.1. How do Content converters work? 

- Normally you save a media file first into the normal file format of the application 
- If you want to save the same file in another format, use the converter program to convert the file to the other 

format. 
 
Example 

- First you have a PowerPoint file 
- To convert the file into Java, you start Impatica for PowerPoint and choose the file 
- You set the converting options in Impatica 
- The application saves the file as Java presentation 
- Now we can present the file in the Web so that most of the internet users can open it. 

 
5.4.2. Examples for Content Converters 
 
Impatica 

- Converts PowerPoint Charts into Java applets. 

 105

- Many effects can be converted: Sounds, Videos, and animation effects. 
 
Presedia Producer 
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ts Powerpoint presentations into Macromedia Flash format. 

 
ordToWeb

- Conver
- Presedia converts most of the PowerPoint 2000 effects 

W  
an separate pages based on the headings of the document 

 

- C
- Can create online tables of contents for documents 

Key Point Summary Conclusions and Recommendations 
 

. Tools for the creation of eLearning websites are for example: 

on 

. Before you design a course with Dreamweaver you should think about the following aspects: 

udience 
 

eme 

. These basic steps help to create a website with Dreamweaver MX 

s 
 

e 

. Practical steps for developing a website with Dreamweaver are: 

rowser 

. Content converters are applications which convert one file format to another 

. Examples for Content Converters are: 

roducer 

1
- Macromedia Dreamweaver 
- Microsoft Frontpage 
- Adobe GoLive 
- NetObjects Fusi
 
2
- Think about your goals 
- Think about your target a
- Think about browser compatibility
- Think about the site structure 
- Think about your design look 
- Think about the navigation sch
 
3
- Define the site 
- Create Template
- Create a Stylesheet
- Set up a Site structur
- Create Pages 
 
4
- Step 1: Create a new folder on your local machine 
- Step 2: Create a new website in Dreamweaver 
- Step 3: Create a template for the website 
- Step 4: Create and add a Stylesheet 
- Step 5: Create your HTML-pages 
- Step 6: Test your website in your b
 
6
 
7
- Impatica 
- Presedia P
- WordToWeb 
 

Study Guide  
ESSENTIAL QUESTIONS FOR THE VERIFICATION OF THE ACCOMPLISHED KNOWLEDGE  

1. 
ou know? 

course? 

What are reasons for using web site tools for eLearning? 
2. What kind of Authoring tools for eLearning websites do y
3. What aspects should you think about before you design an eLearning 
4. Describe important steps for building an eLearning course with Dreamweaver 
5. What are content converters and how do they work? 
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RESPONSES TO THE QUESTIONS  

1. earning: 

many learners can use the content simultaneously. 

 
. Examples for Authoring tools for websites are: 

on 
 

.  
 Think about your goals 

udience 
 

eme 
 

.  
 Step 1: Create a new folder on your local machine 

rowser 
 

. Content converters are applications which convert one file format to another 

 There are many reasons for using web site tools for eL
 Many learners use the Web for learning anywhere 
 If the eLearning content is presented in the Internet 
 It is much easier to update content in the Web than produce new CD-ROMs. 
 It is possible to integrate learning content with other Web offerings. 

2
 Macromedia Dreamweaver 
 Microsoft Frontpage 
 Adobe GoLive 
 NetObjects Fusi

3

 Think about your target a
 Think about browser compatibility
 Think about the site structure 
 Think about your design look 
 Think about the navigation sch

4

 Step 2: Create a new website in Dreamweaver 
 Step 3: Create a template for the website 
 Step 4: Create and add a Stylesheet 
 Step 5: Create your HTML-pages 
 Step 6: Test your website in your b

5
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