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After having learned this lesson you will be more familiar with the following topics: 
� What is an authoring tool?  
� What requirements do you need to use Macromedia Flash MX? 
� How do you create an eLearning movie with Flash MX? 
� What other applications can you use to create eLearning content? 
� How could a small eLearning example with Flash MX look like? 

 
CONTENT OF THE LESSON 
 1. Authoring Tools for eLearning Courses: Overview 
 2. Authoring Tools for eLearning Courses: Macromedia Flash MX 
 3. Tools for creating eLearning Content 
 4. Worked Examples 

 
LEARNING OBJECTIVES:  
After having learned this lesson you will have accomplished knowledge about: 
� Tools for the Development of eLearning Courses 
� Basics for building an eLearning Course with Flash MX 
� How to integrate a Flash MX eLearning Course into the WWW 
� Tools for the Creation of eLearning Content  
� How to develop an eLearning Course in practice with Flash MX 

 
1. Authoring Tools for eLearning Courses: Overview 
 
In a multimedia arrangement there are many different types of media like sound, animation, images or vector graphics. To 
combine these media formats we can use special applications which are called “authoring tools”.  
Typical authoring tools are:  

- Macromedia Director,  
- Macromedia Authorware or  
- Macromedia Flash.  

 
Like a director of a film production the user of an authoring tool can produce multimedia or eLearning content with many 
different types of media files and bring them together into one combination. 
 
Typically authoring tools belong to one of the following types: 
 
Slide based authoring tools:  
These tools use an amount of slides as the basis for the development of a multimedia arrangement. 
A typical slide based authoring tool is Microsoft PowerPoint (see Figure 1). 
 
Advantages of slide based multimedia tools: 

- They are easy to understand 
- You can use them like a book, slide after slide 

 
Disadvantages of slide based multimedia tools: 

- It is difficult to control complex animations in their temporal progress 
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Timeline based authoring tools:  
Like an animated cartoon film these tools use a timeline with a huge amount of little timeframes to represent the multimedia 
content. 
A typical timeline based authoring tool is Macromedia Flash.  
 
Advantages of timeline based multimedia tools: 

- They are an understandable representation of continuous media like films, videos 
- It is easy to control animations in their temporal progress 

 
Disadvantages of timeline based multimedia tools: 

- It is more difficult to understand the timeline concept than the slide based concept 
- For simple presentations it is often more efficient to use a slide based authoring tool like PowerPoint 

 

 
Figure 1: example for a slide based authoring tool (Microsoft PowerPoint) 

 
2. Authoring Tools for eLearning Courses: Macromedia Flash MX 
 
Macromedia Flash MX is a professional authoring tool for producing animations, films and eLearning applications. Moreover 
you can create animated logos, Web site navigation controls, entire Flash Web sites, or Web applications with it. 
 
Basic requirements for Flash MX 
What basic requirements do you need to work with Flash MX? 
 
For Microsoft® Windows there are the following requirements recommended by Macromedia:  

- An Intel Pentium 200 MHz or equivalent processor running 
- Windows 98 SE, Windows ME, Windows NT 4.0, Windows 2000, or Windows XP; 
- 64 MB of RAM (128 MB recommended); 85 MB of available disk space;  
- A colour monitor capable of displaying 16-bit at 1024 x 768 resolution; and  
- A CD-ROM drive. 

 
For the Macintosh you need at least the following hard and software:  

- A Power Macintosh running  
- Mac OS 9.1 (or later) or Mac OS X version 10.1 (or later); 
- 64 MB RAM free application memory (128 MB recommended), plus 85 MB of available disk space;  
- a colour monitor capable of displaying 16-bit (thousands of colours) at 1024 x 768 resolution; and  
- A CD-ROMdrive. 

 
If other users want to see your flash-films, they have to install the Flash Player before. Therefore Macromedia also 
recommends some basic requirements: 
 

- Microsoft Windows 95, Windows 98, Windows ME, Windows NT 4.0, Windows 2000, or Windows XP or 
later; or a Macintosh PowerPC with System 8.6 or later (including OS X 10.1 or later). 

- Netscape plug-in that works with Netscape 4 (or later) in Windows, or works with Netscape 4.5 (or later) or 
Internet Explorer 5.0 (or later) on the Mac OS. 
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- To run ActiveX controls, Microsoft® Internet Explorer 4 or later (Windows 95, Windows 98, Windows Me, 
Windows NT4, Windows 2000, Windows XP, or later). 

- AOL 7 or later on Windows, AOL 5 or later on the Mac OS 
- Opera 6 or later on Windows, Opera 5 or later on the Mac OS 

 
Over 98% of online users today have the Macromedia Flash Player installed.  
A growing number of devices, such as PDAs and smart phones, support it.  
 
Flash MX Help 
Where can you get help inside of Flash MX? 
 
The Macromedia Flash MX package contains a variety of media to help you learn the program quickly and create your own 
Macromedia Flash movies. You can use an electronic version of the manual, an online help, a built-in ActionScript Reference 
panel, interactive lessons, and a regularly updated website. 
 
The “Using Flash MX” manual contains a lot of aspects for the beginner: 

- How to install Flash MX 
- The stage and the workspace 
- Using the timeline 
- Using layers 
- Previewing and testing movies 
- Saving Flash MX documents 
- The drawing and painting tools 
- Working with colours 
- Developing animations in Flash MX 
- Importing and adding sounds to a Flash MX movie 
- Working with graphic objects 
- Working with text 
- Writing scripts in ActionScript 
- Creating interaction with Flash MX 

 
For more information please visit the links: 
http://www.macromedia.com/support/flash/  
http://www.macromedia.com/devnet/flash/  
 
http://www.kirupa.com/developer/index.htm
http://web.ics.purdue.edu/~agenad/help/flash.html  
 
2.1. Basics for building an eLearning Course with Flash MX 
 
Open a new document 
Each time you open Flash MX, the application will open a clear document for you. To open a new document for you own, 
choose: 
File > New 
Click OK 
 
To open a document template from Flash MX choose: 
File > New from Template 
Click OK 
 
The default movie size is 550 x 400 pixels. The minimum size is 1 x 1 pixels; the maximum is 2880 x 2880 pixels. 
To set the size, frame rate, background colour, and other properties of a new document, you use the Document Properties 
dialog box. 
 
The user interface of Flash MX 
In Figure 2 you get an overview of the interface of Flash MX.  
You find the main menu on the top, underneath you see the timeline. On the left side is the tool bar with the most usable tools 
in Flash. On the right side there are some of the available panels with special types of content. 
 
Examples for panels are: 

- Info 
- The library 
- Colour swatches 

http://www.macromedia.com/support/flash/
http://www.macromedia.com/devnet/flash/
http://www.kirupa.com/developer/index.htm
http://web.ics.purdue.edu/~agenad/help/flash.html
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- Colour mixer 
- And so on … 

 

  
Figure 2: the user interface of Flash MX 

 
The stage and workspace 
In every flash movie, time is divided into timeframes which are represented in the timeline. 
On the stage you see at every time what happens in the movie or what kind of film or user interface the user can see in this 
moment when he or she watches the flash movie. 
 

 
Figure 3: the (empty) stage in Flash MX 

 
If you like to change your view of the stage you can change the magnification level or use the zooming tool. 
The maximum magnification depends on the resolution of your monitor and the document size. The minimum value for 
zooming out on the Stage is 8%. The maximum value for zooming in on the Stage is 2000%. 

 
Figure 4: the zooming tool 

 
If you want to zoom in on a specific area of your drawing, drag a rectangular selection marquee with the Zoom tool. Flash 
sets the magnification level so that the specified rectangle fills the window. 
 
The property inspector 
With the property inspector you can change the most common attributes of a document. For this you normally don not need 
special panels or submenus. If the property inspector is not on the screen, please choose: 
Window > Properties 
 
How do you change properties with the property inspector? 
 

- If you have selected anything, deselect all assets  
- Select the Pointer tool. 
- If you want to change the background colour or the frame rate, click on the background of your movie 
- To choose a background colour, click the triangle in the Background colour box and select a colour from the 

palette. 
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- For Frame Rate, enter the number of animation frames to be displayed every second. 
- If you want to change the attributes of a special object, deselect all assets and then select the interesting object 

with the Pointer tool. 
- After this you see the special attributes of the selected object in the property inspector. 
- Now you can change these attributes. 

 
The timeline 
In the timeline you can organize the time and the structure of your objects and scripts in Flash MX. 
For this there are two different possibilities: 
 
Frames 
The frames divide the whole film into small time pieces. Every frame represents a small part of the time the user can see in 
the whole film. The content of the actual frame is visible on the stage. 
 
Layers 
The layers can be seen on the left side of the timeline window. Layers are similar to a couple of film strips which lay one on 
top of each other. Every layer can contain images, vector graphics, text, sound or scripts. 
 

 
Figure 5: the timeline in Flash MX 

 
2.2. Course Design with Flash MX 
 
If you like to develop an eLearning module in Flash MX you have two possibilities: 

- you develop the whole module in Flash MX on your own from scratch 
- you use the Macromedia Flash MX learning interactions 

 
Development from scratch 
To develop a learning module in Flash MX from scratch you need a lot of experience in developing with Flash MX.  
 
Advantages: 

- You can use all the features of Flash for your eLearning content 
- With ActionScript you can use a powerful programming language to realize nearly everything you like to 

 
Disadvantages: 

- Flash MX is a very powerful and complex authoring tool witch contains many features on one hand, but needs a 
lot of basic knowledge on the other hand 

- Maybe it takes more time to build a whole learning module from scratch than using existing material like 
templates, … 

 
Use Macromedia Flash MX learning interactions 
The Macromedia Flash MX learning interactions help you create interactive eLearning content with Flash MX.  
 
Advantages (see also Macromedia user handbook): 

- Anyone with a Flash-enabled web browser can use the instructional content you create. 
- You can customize the interface to meet your needs.  
- Because of using Flash, you can create high-quality interfaces that load quickly and look the same on different 

platforms. 
- You can easily add interactions to your online course with the Flash Learning Interaction components, which 

provide a simple interface for entering data without writing code. 
- Each individual Flash learning interaction can send tracking information to a server-side learning management 

system (LMS) that complies with the Aviation Industry CBT Committee (AICC) protocol. 
- Additionally, the quiz templates track cumulative results from a sequence of interactions and can pass them 

along to the LMS using an enhanced data tracking functionality that conforms to either AICC or Shareable 
Content Object Reference Model (SCORM) standards. 

 
Disadvantages: 

- You have only restricted possibilities to realise your ideas. 
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Course design principles 
To develop a good eLearning course, you should follow some basic principles: 
 
Concrete plan 
The most important basic principle is to have a concrete plan about what you are going to do. If you don’t have, it may 
happen that your eLearning module looks like a series of animations or text files without any connection one to each other. 
 
Knowledge about the learner 
It is nearly not possible to design an eLearning course without any knowledge about the learners of your module.  
How old are they? 
What kind of education do they have? 
Are they interested in the learning matter? 
What kind of knowledge do they have? 
If you answer questions like these before, you get deeper into the needs and interests of your target group. Your learning 
module will be much more adapted to the learners. 
 
Effective project team 
Your team is one of the keys for your success in developing a usable eLearning module. If you have to develop eLearning 
content, in the best case you have a project team containing the following experts: 

- one didactic expert 
- one expert of the learning matter 
- one multimedia author 
- one programmer 

 
2.3. Developing an eLearning Course 
 
Open a film 
When you start to develop an eLearning course you need an empty flash film. 
You have two possibilities: 

- When you open the application a new film will be created automatically 
- Choose: File > New, click OK 

 
Choose the background color, the size of the stage and the frame rate 
Before you start to fill content into the film it is necessary to set up the size of the Flash film. 
After this you can set up the frame rate of the film. The frame rate defines the number of frames displayed every second. 

- Choose Modify > Document or 
- Use the property inspector 
- To set the background color of your movie, click the triangle in the Background Color box and select a color 

from the palette. 
- The default movie size is 550 x 400 pixels 
- Choose 800 x 600 pixels or 1024 x 768 pixels as a usable size for the movie. These screen sizes are typical for 

multimedia productions 
- For a normal animation film or for the web, choose a frame rate of 12 frames per second (fps). 

 
Create keyframes 
The next step is to create some keyframes in the timeline. 
The keyframes are containers where you can fill in new content like text or graphics. 
Without a keyframe you can’t bring any new graphical content into your flash film. 
There are two possibilities for keyframes (Figure 6): 

- Empty keyframes: They contain no graphical content (but maybe scripts or sound) 
- Filled keyframes: They contain graphical content at any rate (moreover maybe scripts or sound) 

 

 
Figure 6: filled and empty keyframes 

 
How do you create keyframes (Macromedia user handbook)? 

- To insert a new frame, choose Insert > Frame. 
 78



Leonardo da Vinci Programme – Project RO/03/B/P/PP175006 

- To create a new keyframe, choose Insert > Keyframe, or right-click (Windows) or Control-click (Macintosh) the 
frame where you want to place a keyframe, and choose Insert Keyframe from the context menu. 

- To create a new blank keyframe, choose Insert > Blank Keyframe, or right-click (Windows) or Control-click 
(Macintosh) the frame where you want to place the keyframe, and choose Insert Blank Keyframe from the 
context menu. 

 
Fill in the text 
Now you can fill in some learning content into the keyframes: 

- Click on the text tool in the toolbar 
- Click on the stage for the set up of a new text 
- Choose the attributes of your text in the property inspector (Figure 7) 

 

 
Figure 7: the property inspector displaying the text attributes 

 
Fill in images 
To insert images on the stage, do one of the following: 

- Choose: File > Import 
- Copy an image file from another application and paste it on the stage in Flash MX 
- Place the image on the stage 

 
Add some learning interactions 
If you would like to develop an eLearning course with the Macromedia learning interactions you have the following 
possibilities (Macromedia user handbook): 

- True or False: In this type of interaction, the user responds to a true or false question. 
- Multiple Choice: The user responds to a multiple-choice question. 
- Fill in the Blank: The user types a response that is checked against matching phrases. 
- Drag and Drop: The user responds to a question by dragging one or more onscreen objects to a target. 
- Hot Spot: The user responds by clicking a region (or regions) onscreen. 
- Hot Object: The user responds by clicking an object (or objects) onscreen. 

 
Now you use one of the following methods (Macromedia user handbook): 

- The quiz templates are designed for scenarios in which interaction-based quizzes are required and tracking is 
necessary. The quiz learning interactions are graphically designed to fit into the quiz format. The quiz templates 
contain a mechanism that counts a cumulative score and starts and stops the necessary tracking in both AICC- 
and SCORM-compliant APIs. 

- The stand-alone interactions are designed for scenarios that require a single interaction, or a series of 
interactions that need to fit into a specific layout within a Flash document. These are available from the 
common library and are graphically designed for stand-alone use. You can track the results for each individual 
stand-alone interaction and submit them to an AICC compatible LMS. 

 
Save the film 
When your film is ready for publishing, you can save the file first and then publish it for playback. 

- Choose File > Save or File > Save as to save the file 
 
 
 
 
 
2.5. Web Integration 
 
Now you can publish your flash film. 
The application creates a Flash SWF file and an HTML file from the normal Flash film by default so that you can integrate 
the film into the web without any problems.  
Moreover you can publish your content in alternative file formats like GIF, JPEG, PNG, and QuickTime. 
 
To set the publish settings for the Flash film, choose: 
File > Publish settings (Figure 8) 
There you can choose the file types you want to publish the flash film in. 
 

 79



Leonardo da Vinci Programme – Project RO/03/B/P/PP175006 

 
Figure 8: the Publish Settings in Flash 

 
To publish the film, do the following steps: 

- Click Publish in the Publish Settings OR 
- Choose File > Publish 

 
3. Tools for creating eLearning content. 
 
There are several tools for the creation of eLearning content. 
A small selection is given below: 
 
Windows Editor 
The easiest way to create content for eLearning is the Windows editor. 
It is simple, easy to use and you can save your results. 
 

 
Figure 9: the Windows Editor for the creation of eLearning text 

 
Microsoft Word 
Word from Microsoft is a powerful and very well known tool for the creation of text (Figure 10). 
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Figure 10: Microsoft Word is a very powerful text creation tool 

 
Macromedia Fireworks 
For the work with images or vector graphics we can use Macromedia Fireworks (Figure 11). 
You can create and modify nearly every type of image and save it in many different file types for print and web. 
 

 
Figure 11: Macromedia Fireworks is a powerful image creation and modification tool 

 
Audacity 
Audacity is a free, easy-to-use audio editor and recorder for Windows, Mac OS X, GNU/Linux, and other operating systems. 
You can use Audacity to: 

- Record live audio.  
- Convert tapes and records into digital recordings or CDs.  
- Edit Ogg Vorbis, MP3, and WAV sound files.  
- Cut, copy, splice, and mix sounds together.  
- Change the speed or pitch of a recording.  
- And more! 

It is easy to understand and more powerful as it looks like. 
For more information you can follow the link: 
http://audacity.sourceforge.net/  
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Figure 12: the user interface of audacity 

 
4. Worked example with Flash MX 
 
In this example we create a small eLearning film with Flash MX and publish it for the Web. 
 
Open a new film 
At first we open a new film in flash: 

- Start Flash MX (it creates a new film automatically) OR 
- Choose File > New 

 
Choose the background colour, the size of the stage and the frame rate 
Now we set the background colour, the size of the stage and the frame rate 

- Choose Modify > Document or 
- Use the property inspector 
- To set the background colour of your movie, click the triangle in the Background Colour box and select a colour 

from the palette 
- Set the background to blue 
- The default movie size is 550 x 400 pixels 
- Set the size of the stage to 800 x 600 pixels 
- Choose a frame rate of 12 frames per second (fps) 
- Click OK 

 
Your stage may now look like this: 
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Figure 13: the stage blue coloured 

 
Build a small interface for the eLearning content 
Before we fill in more keyframes we structure the stage with a few textual elements. 

- Click on the text tool in the toolbar 
- Click in the top middle of the stage and write “Title” 
- Choose text size 36, centered text and colour white for the text 
- Click underneath the title on the left side and open a text field by dragging with the clicked mouse button 
- Write some text inside 
- Choose text size 16 and left text for the text 

 
Create the buttons “next” and “back” 

- Choose Window > Libraries > Buttons 
- Choose two buttons you like 
- Drag one button on the left side and one button on the right side 
- Set the size of the buttons by selecting them and using the scaling tool 
- Click with the right mouse button on the button on the right and choose “Action” 
- Write in the ActionScript window the following ActionScript 
on (release) {  //The left mouse button has been clicked 
    nextFrame();  //go to the next frame in the timeline 
} 
- Do the same with the button on the left and write in the ActionScript window the following ActionScript 

 
on (release) {  //The left mouse button has been clicked 
    prevFrame();  //Go to the last frame in the timeline 
} 
Click in the keyframe in the timeline and write the ActionScript stop 
- So our buttons for the eLearning movie are ready to use. 

 
Your screen now should look like this: 
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Figure 14: the first slide of our eLearning film 

 
Create keyframes 
Now let’s create a few keyframes 

- Choose Insert > Keyframe 
- Fill in about 3 – 4 keyframes in the timeline 

 
Fill in content 

- Fill the titles and bodies with text 
- Your screen now should look like this: 

 

 
Figure 15: the film with buttons and text 

 
Save and publish the film 

- Choose File > Save and save the film with a name you like on the desktop 
- Choose File > Publish 
- Now you find the Flash SWF film and one HTML file with the same name on the desktop 
- If you open the HTML file in your browser you can test your first eLearning flash film ☺ 

 

Key Point Summary Conclusions and Recommendations 
1. You can divide authoring tools into 
- Slide based authoring tools 
- Timeline based authoring tools 
 
2. Macromedia Flash MX is a professional authoring tool for producing animations, films and eLearning applications.  
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Moreover you can create animated logos, Web site navigation controls, entire Flash Web sites, or Web applications with it. 
 
3. Course design principles are: 
- Concrete plan 
- Knowledge about the learner 
- Effective project team 
 
4. The most important steps for the development of an eLearning course with Flash MX are: 
- Open a film 
- Choose the background colour, the size of the stage and the frame rate 
- Create keyframes 
- Fill in the text 
- Fill in images 
- Add some learning interactions 
- Save the film 
 
5. Tools for creating eLearning content for Flash MX are for example: 
- Windows Editor 
- Microsoft Word 
- Macromedia Fireworks 
- Audacity 
 

Study Guide  
ESSENTIAL QUESTIONS FOR THE VERIFICATION OF THE ACCOMPLISHED KNOWLEDGE  

1. What is an authoring tool? 
2. What are the basic requirements for Flash MX? 
3. How do you open a new film in Flash MX? 
4. How do you change the size of a Flash film? 
5. What other applications can you use to create eLearning content? 
 

BIBLIOGRAPHY. REFERENCES 
[1] V. (2002): Using Flash. Macromedia Flash MX, Macromedia Inc., San Francisco 2002  o.
[2] o.V. (2002): Exploring Macromdia Studio MX, San Francisco 2002 
[3] Blatz, C.; Marischka, G. (2001): Flash 5 und ActionScript professionell, Galileo Press, Bonn 2001 
[4] Macromedia, Inc.: www.macromedia.com/support/flash and www.macromedia.com/devnet/flash
 

SUPPLEMENTARY IMPORTANT BIBLIOGRAPHY. REFERENCES.     
[5] Chinnathambi, K.: www.kirupa.com/developer/index.htm  
[6] Purdue University, Teaching and Learning Technologies: http://web.ics.purdue.edu/~agenad/help/flash.html  
[7] Mazzoni, D.: http://audacity.sourceforge.net  
 

RESPONSES TO THE QUESTIONS  
1. In a multimedia arrangement there are many different types of media like sound, animation, images or vector graphics. To combine these media formats 
we can use special applications which are called “authoring tools”.  
 
2.  
For Microsoft® Windows there are the following requirements recommended by Macromedia:  

� An Intel Pentium 200 MHz or equivalent processor running 
� Windows 98 SE, Windows ME, Windows NT 4.0, Windows 2000, or Windows XP; 
� 64 MB of RAM (128 MB recommended); 85 MB of available disk space;  
� A colour monitor capable of displaying 16-bit at 1024 x 768 resolution; and  
� A CD-ROM drive. 

 
For the Macintosh you need at least the following hard and software:  

� A Power Macintosh running  
� Mac OS 9.1 (or later) or Mac OS X version 10.1 (or later); 
� 64 MB RAM free application memory (128 MB recommended), plus 85 MB of available disk space;  
� a colour monitor capable of displaying 16-bit (thousands of colours) at 1024 x 768 resolution; and  
� A CD-ROMdrive. 

 
3.  
Each time you open Flash MX, the application will open a clear document for you. To open a new document for you own, choose: 
File > New 
Click OK 
 
To open a document template from Flash MX choose: 
File > New from Template 
Click OK 
 
4.  

http://www.macromedia.com/support/flash
http://www.macromedia.com/devnet/flash
http://www.kirupa.com/developer/index.htm
http://web.ics.purdue.edu/~agenad/help/flash.html
http://audacity.sourceforge.net/
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- Choose Modify > Document or 
- Use the property inspector 
- The default movie size is 550 x 400 pixels 
- Choose 800 x 600 pixels or 1024 x 768 pixels as a usable size for the movie. These screen sizes are typical for multimedia productions 
 
5.  
For text you can use e.g.: 

� Microsoft Word 
� Any text editor 

 
To create and change images possible applications are: 

� Macromedia Fireworks 
� Adobe Photoshop 

 
 


