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Upon completion of this lesson you will be richer with the following knowledge:  
 Set up a new file and create a simple example  
 Create a navigational structure using the flowchart and icons  
 Add graphics and images to a piece 
 Add user interactions  
 Import a RTF file  
 Package the completed piece using one-button publishing 

 
Content: 
 1. AUTHORING. What is Authorware? 
 1.1 The icon palette 
  
 2. SETTING UP A NEW PIECE. CREATE A SIMPLE „BOOK” EXAMPLE 
  
 3. USIng display icons. CREAting a background for your presentation 
 3.1 Tools palette 
 3.2 Importing an image 
 3.3 Working with text 
 3.4 Modes palette 
  
 4. USIng interactions. Creating a menu 
 4.1 Creating buttons  
 4.2 Positioning objects. 
  
 5. Framework icon. Creating chapters  
 6. Map icon. Creating a page of information 
 6.1 Creating and importing a RTF document. 
  
 7.    one-button publishing. Publish Your “book” 

 
LEARNING OBJECTIVES:  
AFTER LEARNING THIS LESSON YOU WILL ACCOMPLISH THE ABILITY TO: 
 USE AUTHORWARE  
 CREATE LESSONS IN AUTHORWARE 
 PUBLISH CREATED LESSONS IN AUTHORWARE 

 
1. AUTHORING. What is Authorware? 
 
The aim of this chapter is to provide practical training for e-learning and authoring approaches.  For theoretical and 
instructive information about the e-learning functionality and how people can learn from e-courses, you can see chapter: 
”VOCATIONAL EDUCATION AND TRAINING OVERVIEW”. 
Authoring is the act of developing instructional content. This can be done by using specialized software to combine text, 
graphics, sound, animation and digital video into a completed multimedia application (which can be also called multimedia 
piece). Authoring software also offer templates for creating learning courses and features for building tests and quizzes. A 
multimedia piece refers to different types of communication such as:  

• an intranet-based training course; 
• an interactive kiosk; 
• an online magazine; 
• a computer simulation of industrial equipment  

When authoring a multimedia piece, you should follow the same traditional development steps: 
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• Analysis; 
• Design; 
• Development; 
• Evaluation; 
• Distribution. 

Authorware is the leading rich-media authoring software for creating cross-platform interactive multimedia applications. It 
provides tools for producing interactive web and online learning and training applications that use digital movies, sound, 
animation, text and graphics. 
 
Authorware enables you to create multimedia pieces without any programming. The creation of a multimedia piece is a 
simple task of dragging and assembling icons on a flowchart. Organizing the icons into a flowchart you can determine the 
sequence in which Authorware will run them. 
 
The purpose of this lesson is to provide an overview of the latest version of Macromedia authoring package, Authorware 7. 
By creating a very simple application, we will demonstrate some of the useful features that Authorware offers for the 
development of information resources. 
 
There are new features added in Authorware 7 such as: 

• New interface with dockable panels; 
• JavaScript support; 
• XML import and export capability; 
• DVD movies integration; 
• Import PowerPoint presentation into Authorware 7; 
• New properties, functions and variables; 

 
Authorware is a very sophisticated tool that is both powerful and easy to use. It is optimized for building e-learning 
applications. The Authorware 7 screen contains the menu toolbar, workspace and looks like: 

 
Fig. 1 - The Authorware 7 screen 

 
The menu provides quick access to some of the most frequently used menu commands. It contains the icons used for common 
functions (such as create, open or save an application). 
 
1.1 The icon palette 
 
The toolbar or the icon palette contains 14 icons used to create Authorware pieces. To create your pieces, drag icons from the 
icon palette into the flowchart from your workspace. This is the way you can produce a sequence of actions that Authorware 
will execute. Below you can find a list with all 14 icons (and a short description) that Authorware provides you to create a 
piece.  

 - Display icon - displays text and graphics on the screen; 
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- Interaction icon - gives users a variety of ways to make choices (clicking buttons or hot spots…); 

 
- Motion icon - moves an object along a path or to a specific point; 

 
- Calculation icon - updates values in variables or executes functions; 

 
- Erase icon – erases some or all objects from the screen; 

 
- Map icon – groups   the flowchart into smaller segments; 

 
- Wait icon - adds pauses with or without onscreen buttons that let users decide when to continue; 

 
- Digital movie icon - plays Director 5 and earlier, AVI, MOV, FLC, MPEG, and QuickTime 2 digital 
movies; 

 
- Navigate icon - sets up automatic or user-controlled navigation in a hypermedia framework; 

 
- Sound icon - includes music, narration, or sound effects in a piece; 

 
- Framework icon - creates a hypermedia framework, a structure of text, graphics, sound, animation, and data 
that users can navigate through; 

 
- DVD icon - includes still images, sound, or movie from DVD; 

 
- Decision icon - sets up various paths Authorware can take depending on conditions and events; 

 
- Knowledge Object icon – includes Knowledge Objects; 

 
There are two extra tools you can use in order to develop your application. You can use the icon color palette to organize 
icons by color them. Also you can use the start and stop flags which speeds up development by letting you test segments of 
the flowchart. The start and stop flags are usually used together.  
Inserting an icon is a very simple task. You can drag it from the icon palette directly to the workspace and place it on the 
flowchart where you want to insert it. 
 
2. SETTING UP A NEW PIECE. CREATE A SIMPLE „BOOK” EXAMPLE 
 
Hopefully by the end of this lesson you will have an understanding of the way that Authorware works and also be able to 
create a basic book example, even if Authorware is capable of creating much more than this. First of all you have to create a 
new project. Select New -> File from the FILE Menu and the New Project window will appear. You can select a Knowledge 
Object for the new file, but in our case we don’t need one, so click the “None“ button to create an empty file. This creates a 
new workspace for your piece. A workspace is also known as a design window. 
 After that, you should save the new project. To save and name the project, select Save from the File Menu and type “Book ” 
in the File Name text box. Don’t forget to save your work frequently. 
Before you start creating the project, you should setup some display properties for the application to determine the 
appearance of the presentation window, such as the size of the window and whether or not a title bar and menu will be 
included. Also you can make the window to be centered on the screen.  
The presentation window shows what the user will see when the Authorware piece runs. You can edit directly in the 
presentation window to add, change, or reposition graphics, text, and interaction objects.  Select File -> Properties from the 
Modify menu and the Property window (Fig. 2) will be displayed.  

 
Fig. 2 – File Properties 
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You have to switch the following options to these settings (or as you can see in the Figure 2) and leave all other options on 
their default settings:  

Center on Screen – checked; 
Title Bar – unchecked;  
Menu Bar – unchecked;  
Size - 640 x 480;  
Select a color for your background (light gray); 

  
The piece that you’ll create does not require a menu bar, which includes a File menu with the Quit command, or a title bar, so 
you will specify that these items not be included. Additionally, you will configure the presentation window to appear centered 
on the user’s screen. 
 
When selecting the appropriate screen size for the presentation window, specify a size no larger than the smallest monitor that 
you anticipate your audience will use. If you specify a larger size, part of the window might get cut off on the user’s 
computer. For this tutorial, you’ll select a 640 x 480 window, a size designed for most standard monitors. 
 
3. USIng display icons. CREAting a background for your presentation 
 
Drag the display icon from Icons Toolbar into the flowchart in the workspace (design window) and name it “background” (in 
the right of the icon).  
 
You can use the display icon to display text and graphics. To modify the display and layout of a display icon, you can select 
the icon you just added, and select Icon -> Properties from the Modify Menu. The display icon properties dialog box will 
appear.  
 
To add graphics and text to a display icon you should use the presentation window and to add contents to a display icon’s 
presentation window, use the Toolbox to draw objects or to write texts. Also you can import images, or drag and drop text or 
graphics files into the display icon. 
 
3.1 Tools palette 
 
If you double click the icon just added, the presentation window and tools palette will appear. The tools palette contains lots 
of tools that you can use in the presentation window. Below you can find a list of tools that Authorware provides you: 

 
- Pointer – Selects and moves objects in the presentation window. You have to click an object to select it or 
shift-click to select more than one object. To move an object, you should drag the center of a filled object; 

 
- Text tool – Creates and edits text. Click in the Presentation window to create a new text object. Click an 
existing text object to open it for editing; 

 
- Rectangle tool - Draws a rectangle. Click and drag to draw a rectangle or click and shift-drag to draw 
a square; 

 
- Straight Line tool - Draws horizontal, vertical, or 45° lines. Click the start point and drag to draw a line. The 
line snaps to a horizontal, vertical, or 45° position; 

 
- Oval tool - Draws an ellipse. Click and drag  to  draw  an oval or click and shift-drag to draw a circle; 

 
- Diagonal Line tool - Draws a line between any two points. Click the start point and drag to draw the line; 

 
- Rounded Rectangle tool - Draws a rectangle with rounded corners; 

 
- Polygon tool - Draws irregular polygons or multi-line objects. Click to create the polygon’s corners and 
double-click the last point to complete the polygon. You can drag the points to modify the line; 

 
 
3.2 Importing an image 
 
In the presentation window of the display icon you just added, you can draw the background for your book using the tools 
from the palette. Instead of using the tools palette you can import an image for your background. Select Import and Export -> 
Import Media from the File Menu and the “Import Which File?” dialog box appears. Use the dialog box to select the file you 
want to import or type the name of your image file in the File Name text box. There are different kinds of image formats you 
can choose (BMP, Jpeg, PNG, GIF and others). Note that the size of the image you want to import should not exceed the size 
of the presentation window, because you will not be able to see the whole image. 
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You can import multiple files at a time. To import more than one file you should click the plus sign in the lower right corner 
of the “Import Which File?” dialog box. The dialog box will expand and lets you create a list of files to import. The “Files to 
Import” list shows the files selected for importing. To add a file to the list, select one and click “Add”. To add all the files 
shown in a specific folder, you can click “Add All”. To remove a file from the import list, select the filename and click 
“Remove”. When you click “Import”, all the listed files in the list are imported into your application. In this example you 
don’t need to import multiple files because you want only a background image. 
If you don’t have an image available for the background you can draw a dark gray rectangle in the upper side of the 
presentation window. You can draw a rectangle by using the tools palette. 
 
3.3 Working with text 
 
Create another display icon to set the title of your book. Drag the display icon from Icons Toolbar into the flowchart below 
the first display icon you added earlier (for the background) and name it “Title” (in the right of the icon). Double click is to 
open the presentation window. You’ll create a text object that will be a title for the piece.  Using the toolbox, select the text 
tool, then in the presentation window, click toward the upper left corner and type “Learning AUTHORWARE”. The line 
above the text   shows the margin width.  
You can perform different operations with the text. For example to change the size of the text, select the entire line of text and 
select Size  -> Other from the Text Menu and type 18 in the “Font Size“ text box. To make the text margin narrower, click 
the small square margin handle (not the dark triangle) at the right end of the margin line, and drag it toward the end of the 
word “AUTHORWARE”. Take care that the word AUTHORWARE doesn’t pass to the next line. 
 

 
Fig. 3 – The margin handle 

 
3.4 Modes palette 
 
To make the text to be transparent, verify that it’s still selected and select Inspectors -> Modes from the Window Menu and 
choose Transparent from the Modes palette. There are six modes available in Authorware. You can find a brief description of 
each mode in the table below: 

 
- Opaque mode – objects in opaque mode cover the background. This mode makes the object to hide 
everything behind it in the piece. Opaque is the default mode for bitmapped objects; 

 

- Matted mode – this mode acts like opaque mode, but white space is removed from around the edges of 
bitmapped objects. White space inside the object remains; 

 

- Transparent mode –an object in transparent mode permits its background to show through any white 
within the object or around the edges; 

 

- Inverse mode – this mode inverts colors against a nonwhite background. Only colored areas of an object 
become inverted and its white areas become transparent. This happens only when the object appears above 
a colored background, otherwise, above a white background, it displays normally; 

 

- Erase mode - shows only the background through an object’s outline. This mode produces uncertain 
results for color bitmapped objects; 

 

- Alpha mode – this mode uses graphic’s alpha channel. The alpha channel effect makes an image to blend 
in with the image behind it; 

If you have selected the Transparent mode for your text, you can change its color. You can select a color depending on the 
background. Also you can choose the Inverse mode and the text will automatically appear light against dark backgrounds and 
dark against light backgrounds.  
 
4. USIng interactions. Creating a menu 
 
After creating the background you are going to create two chapters of your very simple book example  “Learning 
Authorware”. Each chapter will consist of two pages. This will enable you to gain an understanding of how navigation works 
within Authorware. 
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So that you can access the pages of the chapters you need to create a menu. This can be done with help of the interaction icon. 
Drag the interaction icon into the workspace below the background and title icons and type “Menu” in the textbox from the 
right side of the icon. The interaction icon lets a program respond to user input 
 

 
Fig. 4 – Interaction icon 

 
The interaction icon works in part like a display icon because you can use it to display text and graphics that you want to 
appear throughout the interaction. It also displays buttons, menus, text-entry fields, and other elements that allow users to 
respond to an interaction.  
 
When Authorware encounters an interaction icon on the flowchart, it waits until a user responds to the interaction. After that 
it continues down the flowchart. For example, if you display a button on the screen, Authorware waits until a user has clicked 
on it before it continues. 
There are three basic components of an interaction: 

• a way to interact - a button to click, a menu to select or a textbox to enter text; 
• a response  -  the action that user takes; 
• the result -  anything that Authorware can do in response to a user’s action; 

If you set up a button, you expect users to click it or if you set up a text box, you expect them to type some text in it, but users 
do not always do what you expect them to do. Any response that you suppose that a user can make is called a target response. 
 
4.1 Creating buttons  
 
Supose that you want to create two buttons for the menu: first button, “Introduction”, which will navigate to the “Introduction 
to AUTHORWARE” chapter and second button, “Using icons”, which will navigate to the “Icon palette in 
AUTHORWARE” chapter. We have already created an interaction icon (Menu). For this icon to work, you need to create 
some buttons, which will navigate to a specific page in the chapter. We can create buttons using navigate icon. Drag the 
navigate icon from the palette icon into the workspace at the right side of the menu interaction icon and verify that “Button” 
is selected in the Response Type dialog box. 
 
Then click OK. Name the navigate icon you have just created, as “Introduction”. There are 11 different Response Types to 
choose from: 

• Button -  a simple button interaction; 
• Hot Spot - rectangular portions of a display; 
• Hot Object - the actual object is hot, not just a rectangle; 
• Target Area - a user may drag an object;  
• Pull-down Menu - lets user select from a menu at the top of a Presentation Window; 
• Conditional - displays content based on some condition, such as the value of a variable; 
• Text Entry - lets user enter input into a text box; 
• Keypress - responds to particular keypress inputs; 
• Tries limit - forces a branch after a certain number of tries;  
• Time limit - forces a branch after a certain amount of time;  
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• Event - replays to an object created by an Xtra, such as an ActiveX control 
 

 
Fig. 5 – Navigate icon 

 
When encounters a navigate icon, Authorware goes to the page that you define as a destination. This will be done later after 
you will create the pages for your book. 
Double click the “Introduction” response symbol to open its response property window. You can find the response symbol 
(it’s a small rounded rectangle) above the “Introduction” navigate icon. 
 

 
Fig. 6 – The response symbol 

 
In the response property window, click “Buttons” to display the standard set of buttons provided with Authorware and verify 
that the button with the description “Standard Windows Button System” is selected. Then click OK. This is a grey button 
with text in the middle, just like you see on a normal application. 
 
Note that if you have some images available you can create some nice buttons which change as you move your cursor over 
them or when you click on them. To do this, instead of selecting “Standard Windows Button System”, create a new button by 
clicking the “Add” button. The “Button Editor” window will appear. Here you can import images for your button states (up, 
down, over and disable) 
 
Each button has several “states”. Each of theese states can have a different graphic, label and sound assigned. You can create 
buttons which can have one or multiple states:  

up - this is the default state which shows when the button is inactive; 
down – this state is used when the user clicks on the button; 
over – use this state when the mouse cursor is over the button; 
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disabled -  a state used when the button is disabled; 
 

 
Fig. 7 – Button Editor 

 
You need to erase the menu buttons before the pages of info appear. In the response property window goes to the “Response” 
tab and selects “Before Next Entry” in the “Erase” field. Another option that you have to check is “Hide When Inactive” from 
the “Button” tab. Use this option to remove the button from the screen when it is inactive. The button automatically reappears 
when it becomes active.  
 
You need to create one more button for the menu, which will navigate to the “Icon palette in AUTHORWARE” chapter. You 
have to follow the same steps when you create the “Introduction” button. 
 
Drag the navigate icon from the palette icon  into the workspace at the right side of the “Introduction” navigate icon and 
verify that “Button” is selected in the Response Type dialog box. Name this navigate icon as “Using icons”. Double click the 
“Using icons” response symbol to open its response property window and click “Buttons” to display the standard set of 
buttons provided with Authorware. Verify that the button with the description “Standard Windows Button System” is 
selected. Click OK and go to the “Response” tab and select “Before Next Entry” in the “Erase” field. Don’t forget to check 
the “Hide When Inactive” option from the “Button” tab. After creating the second button, the flowchart should look like this: 
 

 
Fig. 8 – Flowchart  

 
4.2 Positioning objects. 
 
The easiest method of positioning objects on the screen is to start your application by selecting Restart from the Control menu 
(or by pressing Ctrl + R), and then pause the application at the appropriate point. The application can be paused by selecting 
Pause from the Control menu (or by pressing Ctrl + P). When application is paused you can move objects to the required 
position. 
 
Move the buttons to an appropriate position then stop the application by selecting Stop from the Control menu. 
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Fig. 9 – Presentation window 

 
5. Framework    icon. Creating chapters  
 
As mentioned earlier, it is possible to create complex interactive applications in Authorware, the creation of “electronic 
books” is very easy. It’s time to create the two chapters of your book. Use the framework icon to create a template for all the 
pages of information in that chapter. The framework icon contains navigation icons, titles or common images that will appear 
on all the pages within the chapter. 
 
Drag the framework icon into your workspace below the Menu interaction icon and call it “Chapter 1”. If you double click 
this icon, you can see that the framework icon created a set of navigation buttons as standard. For this simple application you 
will create a set of your own navigation buttons. Delete all the icons in this workspace by clicking on each icon and pressing 
the delete key.  
 
Within the framework icon it is possible to design an environment to make creating navigation easy. The framework 
workspace has two parts: an entry pane and an exit pane. When Authorware enters the framework, it first goes to the 
flowchart in the entry pane. The icons in the entry pane affect every page that is attached to the framework icon. For 
example, if you set up a display icon in the entry pane to display a background, the background appears on every page. 
 
Before Authorware exits the framework, it goes to the flowchart in the exit pane. Anything you set up there happens each 
time Authorware leaves the framework. For example you can change the value of a variable each time a user exits the 
framework, by setting up a calculation icon in the exit pane. Another thing to mention that Authorware does before it exits 
the framework is that it erases everything in the entry pane and in any page in the framework. 
 
To enable the user to cycle through your pages, the system requires forwards and backwards buttons. You will also need a 
button to take users back to the main menu. 
First of all you need a title for this chapter. Drag a display icon into the flowchart, double click it to open the presentation 
window and insert the title of the first chapter using the text tool. Write the following text: “Introduction to 
AUTHORWARE”. Change the size of the text to 10 and align it to the right side of the presentation window. 
 
Using the same procedure used to create the menu items, create an interaction called “Navigation” to enable the user to 
navigate around the pages. Name the buttons, “Next”, “Previous” and “Menu” 
Double click the “Chapter 1” framework icon and a workspace window will appear. Delete the standard content of this 
workspace window (if you didn’t do that earlier) and drag an interaction icon into the entry pane flowchart. Name it 
“Navigation 1”. Drag three navigates icons on the right of the interaction icon you have just created, as you can see in the 
figure below. 
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Fig. 10 – Chapter 1 

 
For all navigate icons, select “Button” in the Response Type dialog box. Double click the response symbol of the “Previous” 
navigate icon, press the “Buttons” and select “Navigation, Previous Page” as a button for this icon. Follow the same steps for 
the other two navigate icons. For “Next” navigate icon select “Navigation, Next Page” and for “Menu” navigate icon select 
“Standard Windows Button”. Of course you can use custom images for this buttons if you have some available by clicking 
“Add” in the “Buttons” window. You already should know how to add custom images to the buttons. 
 
You have to create the navigation button links. Authorware has built-in functions to move forwards and backwards through 
pages of a chapter. To apply the functions to your buttons is very easy. Double click on the one of the navigate icons in the 
workspace to open its properties dialog box and select “Nearby” from the “Destination” combo box. Then select the 
appropriate option for each button as you can see in the list below: 

• Previous button –  Selects the “Previous” option; 
• Menu button – Selects “Exit Framework/Return” option; 
• Next button – Selects “Next” option; 

 
You can define the type of destination by creating a navigation link. You can go forward or backward or jump to a specific 
page, search for text, or jump to the first or last page of a framework. There are two ways you can use navigate icons: 

• Automatic navigation - places a navigate icon anywhere on the flowchart and Authorware executes the link and 
goes to the destination page. This is done automatically when Authorware encounters the navigate icon,  

• Navigation controlled by the user - creates a navigation framework by adding one or more navigate icons to an 
interaction icon. The interaction icon can be placed on the main flowchart or in the entry pane of a framework 
icon. Every time you add a navigate icon to an interaction icon, it is necessary to set up a navigation control 
(such as a button or a hot spot) that takes the user to a destination page. 

 
6. Map icon. Creating a page of information 
 
Now you should close the workspace for the “Chapter 1” framework. If you want to create pages of information you can use 
the map icon. The map icon is a helpful icon, used to group several other icons together. 
To create a page of information for your first chapter, drag the map icon from the icon palette to the right of your “Chapter 1” 
framework icon and name it “Page 1”. If you double click on this icon you can see its workspace. The content for the first 
page of chapter one will be imported from a RTF (Rich Text Format) file. 
 
6.1 Creating and importing a RTF document. 
 
One useful feature of Authorware is the ability to import text from word processors using the “Rich Text Format”. This 
format stores information about font size and type or text alignment. Most word processors can store documents in this 
format.  
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Before importing a RTF document, you should create one. You can use any simple word processing program, like Word Pad, 
to create RTF documents but you can also use the “RTF Objects Editor” available within Authorware. Select “RTF Objects 
Editor” from the “Commands” menu and write the following text in the editor: 
“Authoring is the act of using different kind of software to combine text, graphics, sound, animation and digital video into a 
completed multimedia application (which can be also called multimedia piece). Multimedia piece is a global term that can 
refer to many types of communication such as: an intranet-based training course, an interactive kiosk, an online magazine, a 
computer simulation of industrial equipment.  
Authoring a multimedia piece generally follows the traditional development process of analysis, design, development, 
evaluation, and distribution.” 
 
After writing the text above save the file as “chapter1.rtf” and close the “RTF Objects Editor”. Be sure that the “Page 1” 
workspace is opened. From the File menu select Import and Export -> Import Media and choose the file “chapter1.rtf”. 
Double click the “chapter1.rtf” displays icon to open the presentation window, resize the piece of text and change the 
following properties. 

• Size – 14; 
• Alignment – Justify; 
• Mode – Transparent; 

 
You have to create the link between the menu buttons and first chapter. Play your application and click on the “Introduction” 
menu button. You will be presented with the window you used earlier to create the forward and backward buttons. Select the 
option “Call and Return” and “Page1” from the list. The link is created and you are able to navigate to the “Introduction to 
AUTHORWARE” page. Your presentation should look something like this: 
 

 
Fig. 12 – “Introduction to AUTHORWARE” page 

 
It’s time to create another page of information for the first chapter. Follow the same steps when you create the first page and 
select the same properties for the text, after you have written the following text in the “RTF Objects Editor”:  
“Authorware is the leading rich-media authoring tool for creating cross-platform interactive multimedia pieces. It provides 
tools for producing interactive web and online learning and training applications that use digital movies, sound, animation, 
text and graphics. Authorware enables you to create applications without any programming. The creation of a multimedia 
piece is a simple task of dragging and assembling icons on a flowchart. The flowchart organizes the icons and determines the 
sequence in which Authorware runs them.” 
 
7. one-button publishing. Publish Your “book” 
 
After creating your piece you should publish it for the web, CD-ROM or corporate network. This can be done with only one 
click. Authorware provides the “one-button publishing” feature which is a sophisticated process and lets you implement it 
only in one click. 
 

 119



Leonardo da Vinci Programme – Project RO/03/B/P/PP175006 

Before you publish your piece you should create the second chapter of your book. A solution is given in “Questions and 
Answers” section.  
In the “Publish Settings” dialog box you can view and modify the way in which Authorware publishes your files. After 
saving the piece, select Publish -> Publish Settings from the File Menu (or press CTRL+F12) to open “One Button 
Publishing” dialog box. 
 

 
Fig. 13 – “One Button Publishing” dialog box 

 
On the “Formats” tab, the default settings include options to publish for a CD, for the Authorware Web Player, and embedded 
in an HTML file. On the “Files” tab you can see the files that Authorware will include in the published package (the source 
location, destination, and description). When you finish viewing the publish settings, click “Publish” button and Authorware 
begins to publish your piece. Another way to do this is to select Publish -> Publish from the File Menu (or press F12). 
 
To view your piece in a web page, browse to the application folder (the folder where you saved your piece). There you can 
find a folder named “Published Files” created by Authorware during the publishing process. Open this folder. Within the 
“Web” folder is an HTM file. The HTM file includes OBJECT and EMBEDS tags to play your packaged Authorware file. 
Open the HTM file in a web browser to play your published piece. 
 

QUESTIONS 
1) What is Authorware? 
2) How do you create a new project in Authorware? 
3) Which mode removes the white space from around the edges of bitmapped objects? 
 a) – matted mode; 
 b) – transparent mode; 
 c) – inverse mode; 
 d) – alpha mode; 
4) What makes Authorware when encounters a navigate icon? 
5) What’s a “map icon” used for? 
6) How do you publish your piece? 
7) Create the second chapter, Using Icons in Authorware, for your book example.  
 

ANSWERS 
1) Authorware is the leading rich-media authoring tool for creating cross-platform interactive multimedia application. It provides tools for producing 
interactive web and online learning and training applications that use digital movies, sound, animation, text and graphics. 
2) Create a new project by selecting New -> File from the FILE Menu. Before you start creating the project, you should setup some display properties for the 
application. 
3) The correct answer is a). 
4) When Authorware encounters a navigate icon, it goes to the page you set up as a destination.  
5) Map icon is used to group several other icons together. 
6) You can publish you piece using “one-button publishing” feature of Authorware by selecting Publish -> Publish from the “File” menu. 
7) Before publishing your piece you should create the second chapter of the book. Drag a framework icon into the flowchart and place it below the “Chapter 
1” framework. Name it “Chapter 2”. Double click it and create the title for this chapter using the display icon. Below the title display icon, you have to create 
the navigation through this chapter (previous, next and menu buttons and links). This is the same as the one you created for the first chapter so you can copy 
it. Double click the “Chapter 1” framework icon and select the “Navigation 1” interaction icon and all its components (the three navigate icons: Previous, 
Menu, Next). Select “Copy” from the Edit Menu then double click the “Chapter 2” framework icon and  paste the copied content below the title display icon. 
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 Then, create two pages of information by dragging two map icons to the right of the “Chapter 2” framework icon. You can use either “RTF Objects Editor” 
or the text tool to insert some text into the pages (you can use some text from the “Icon palette” chapter of this lesson). Double click the “Using icons” 
navigate icon and select the proper page (Page 1 of chapter 2) to navigate to.  
 

KEY POINT SUMMARY CONCLUSIONS AND RECOMMENDATIONS 
As a conclusion it can be said that Authorware provides a lot of flexibility in the scripting functionality. 
 

BIBLIOGRAPHY. REFERENCES.    
Using Authorware 7 - Macromedia AUTHORWARE help ; 
 

SUPPLEMENTARY IMPORTANT BIBLIOGRAPHY. REFERENCES.   (www)  
 
http://livedocs.macromedia.com
 

SUPPLEMENTARY INDICATIONS ABOUT THE CONTENT OF THE LESSON 
Authorware is a powerful tool used for developing instructional content. It offers templates for creating learning courses and features for building tests and 
quizzes. 
 

WORDS TO THE LEARNER: I strongly recommend you to read this lesson and to 
practice all exercises.   

 
 

http://livedocs.macromedia.com/
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